Share This Page

Important Message for Android Users

February 2018
Share This Story

To ensure secure banking and protection of your personal details and accounts, users will need to have Android 5.0 or above in order to access the app, internet banking and website.

We encourage you to ensure your devices use the latest operating systems at all times to protect your information online and continue to access your banking.

Top

Share this page

×

For the security of your accounts, Internet Banking no longer supports Internet Explorer 8 or earlier versions.

As you may know, Microsoft recently made the decision to discontinue its support of Internet Explorer 8 (IE8). This leaves users exposed to potential security risks. As a result, Beyond Bank's Internet Banking will no longer support Internet Explorer 8 or earlier versions. Going forward, Beyond Bank will support Internet Explorer 9 or later to ensure the security of your accounts.

Continue to Website